Help with installing JMRI's Decoder Pro?

Affiliate Disclosure: We may receive a commision from some of the links and ads shown on this website (Learn More Here)

NP2626

Well-Known Member
#41
I have Downloaded the JMRI Decoder Pro program again and tried loading a locomotive into the program. After doing so, the loco will not run. So, i have used Digitrax's SoundLoader to set the CVs back to factory, ran the loco on 03 and then used SoundLoader to install the locomotive's number as its' address and it is working, now. I need to worm my way though Decoder Pro and determine what I am doing wrong.
 
Last edited:

NP2626

Well-Known Member
#42
The re-downloading of the program did not help, attempting to use JMRI's Decoder Pro disables my locomotives. I have gone to JMRI's User Group website and discussed what is happening to me when I use Decoder Pro and there have been several very good questions and suggestions on what to try all to no avail. I may end up uninstalling the Decoder Pro software and using Digitrax's SoundLoader, even though I really like what JMRI's Decoder Pro could do for me! Such is life!!
 

tootnkumin

Well-Known Member
Staff member
#44
You're not trying to use the "Test" version are you Mark? the one they put out for their developers to experiment with.
 

NP2626

Well-Known Member
#46
Last Friday I joined the JMRI UsersGroup and asked for help. A good thread ensued, excepting some caustic comments by people with nothing better to do and a few people hijacked my thread, with there own not necessarily on-topic posts. I felt this forum to be terribly confusing as it was. Then, yesterday, there ended up being three new threads using my thread's title as there own. This morning I just ended my association with that forum!
 

tootnkumin

Well-Known Member
Staff member
#47
I downloaded Version 4.14. Toot, are you a JMRI Decoder Pro user?
No, not yet. I tried many years ago but was only a computer novice at the time (now I'm an apprentice novice), the terminologies used had me stumped. I noticed that 4.14. is latest user version. They always seem to have a developer one going as well to get ready for the next one. I wondered if maybe you had got that one and that's where the difficulties came from.
 

Iron Horseman

Well-Known Member
#48
I noticed that 4.14. is latest user version. They always seem to have a developer one going as well to get ready for the next one.
It is an open source project. There could be hundreds of people independently working on it. I don't know how they decide what of those contributions goes into the "production" versus the "user" releases. Controlling an open source project is often like herding cats.
 

NP2626

Well-Known Member
#49
My JMRI Decoder Pro is for the most part working. Once in a while I have a locomotive I've put into the roster that will not operate and I need to fool around with some, to get it to work. The person from the JMRI User's Group that was helping me out, doesn't know what is going on with my Decoder Pro. However for the most part, because it is working most of the time, feels he can't help me out much more, so I am going to leave it alone.
 



ModelRailroadForums.com is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com

Top