Getting started with JMRI for Signalling

Affiliate Disclosure: We may receive a commision from some of the links and ads shown on this website (Learn More Here)

RailroadBookstore.com - An online railroad bookstore featuring a curated selection of new and used railroad books. Railroad pictorials, railroad history, steam locomotives, passenger trains, modern railroading. Hundreds of titles available, most at discount prices! We also have a video and children's book section.

ModelRailroadBookstore.com - An online model railroad bookstore featuring a curated selection of new and used books. Layout design, track plans, scenery and structure building, wiring, DCC, Tinplate, Toy Trains, Price Guides and more.

#1
Hello all,
I posted a thread a few weeks ago regarding the selection of hardware to run a set of interlocking signals on an HO layout. I'm very new at this and lost.
I've been trying to get familiar with setting up the hardware and programming but am not having much luck.

Hardware: Digitrax DB150 command station, Digitrax PR4 decoder programmer, Digitrax SE8C decoder, and an Azatrax MDR6 for sensors.

I've installed JMRI Decoder Pro and Panel Pro. Having connected all the hardware, I've been able to power on the test signal and change signal indications using the control panel in PanelPro. However, when I attempt to create my own panel I do not get any communication between the PR4 and SE8C. It seems there's limited information online about how to set everything up in JMRI.

From what I've read and tested I suspect in creating a new panel, I first have to add the SE8C to the program using Decoder Pro, which I've done. When I'm logged into PanelPro using the example provided, under LocoNet I can see an option to configure the SE8C. But in my own setup I do not and have not been able to figure out how to add it. It would be great if there was a procedural list of how to set up the basics to establish communications between the PR4 and decoder. In the attempts I've made to add the SE8C, I get error 302 unable to communicate with decoder.

Can anyone point me to a manual or something to reference on how to set things up?
I'm also confused on how to setup signal heads/masts, etc. Initially things like choosing Username and SystemName for each signal, though I'm assuming the SystemName corresponds to the hardware address on the decoder.
 





ModelRailroadForums.com is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com

Top